Google is deprecating Play Services support for Android Jelly Bean

Google announced Android Jelly Bean in June 2012. The update spanned across Android versions 4.1 to 4.3.1 released in 2013, and was followed up by version 4.4, dubbed “KitKat”. Now, after nine years of support, the firm is finally deprecating Play Services support for the operating system.

Google has explained that Android Jelly Bean is currently present on less than 1% of active devices and considering that the OS does not support a bunch of modern capabilities, developers have to spend a lot of time on workarounds. As such, it is deprecating support for Google Play Services on this flavor of the OS. APK version 21.30.99 scheduled for release in August will be the last supported version.

This change affects developers utilizing API levels 16, 17, 18 as the minimum version in their SDK. While the functionality present in existing versions of the SDK will continue to work, newer components may not support these API levels, which means that developers will be hit with errors when trying to build their app.

There are two workarounds for this problem. The first and obvious one is to change the minimum SDK level to 19. The impact of this is that users on Android Jelly Bean and older devices will not be able to see or download updates to the app. That said, given the few number of users actively using these devices, Google does not believe that this impact will be massive. The second workaround involves building multiple flavors of your app. One version for modern devices and the other for legacy handsets. Of course, there are compatibility caveats to consider with this approach as well, so we recommend that you have a look at Google’s documentation here.

Leave comment

Your email address will not be published. Required fields are marked with *.